*/*: Drop stable ia64 keywords
[gentoo.git] / app-emacs / google-c-style / google-c-style-20140929.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp readme.gentoo-r1
7
8 DESCRIPTION="Provides the google C/C++ coding style"
9 HOMEPAGE="https://github.com/google/styleguide"
10 SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.gz"
11
12 LICENSE="|| ( GPL-1+ Artistic )"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15
16 S="${WORKDIR}"
17 SITEFILE="50${PN}-gentoo.el"
18 DOC_CONTENTS="Example usage (~/.emacs):
19         \n\t(add-hook 'c-mode-common-hook 'google-set-c-style)
20         \n\t(add-hook 'c-mode-common-hook 'google-make-newline-indent)"