app-emacs/pymacs: Readd support for python 2.7.
[gentoo.git] / app-emacs / gnuplot-mode / gnuplot-mode-0.7.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit readme.gentoo elisp
7
8 DESCRIPTION="Gnuplot mode for Emacs"
9 HOMEPAGE="http://xafs.org/BruceRavel/GnuplotMode"
10 SRC_URI="https://github.com/bruceravel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
15 IUSE="doc"
16
17 DEPEND="doc? ( virtual/latex-base )"
18 RDEPEND="sci-visualization/gnuplot[-emacs(-)]"
19
20 SITEFILE="50${PN}-gentoo.el"
21
22 src_configure() {
23         econf \
24                 EMACS="${EMACS}" \
25                 --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
26 }
27
28 src_compile() {
29         emake
30         use doc && emake pdf
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install
35         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
36
37         dodoc README.org
38         use doc && dodoc gpelcard.pdf
39
40         DOC_CONTENTS="Please see ${SITELISP}/${PN}/gnuplot.el for the
41                 complete documentation."
42         readme.gentoo_create_doc
43 }