app-emacs/*: drop to ~hppa
[gentoo.git] / app-emacs / elscreen / elscreen-20180321.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp
7
8 DESCRIPTION="Frame configuration management for GNU Emacs modelled after GNU Screen"
9 HOMEPAGE="https://www.emacswiki.org/emacs/EmacsLispScreen
10         https://github.com/knu/elscreen"
11 SRC_URI="https://github.com/knu/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2+ GPL-3+"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~ppc64 sparc x86"
16 IUSE="wanderlust"
17
18 RDEPEND="wanderlust? ( app-emacs/wanderlust )"
19 BDEPEND="${RDEPEND}"
20
21 SITEFILE="50${PN}-gentoo-${PV}.el"
22 ELISP_REMOVE="elscreen-dnd.el"  # does not compile
23 DOCS="Readme.md GF-README GF-QuickStart"
24
25 src_prepare() {
26         elisp_src_prepare
27         use wanderlust || rm elscreen-wl.el || die
28 }