Merge the GLEP 67 transition changes
[gentoo.git] / app-emacs / edb / edb-1.31.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit elisp
8
9 DESCRIPTION="EDB, The Emacs Database"
10 HOMEPAGE="http://www.gnuvola.org/software/edb/
11         http://www.emacswiki.org/emacs/EmacsDataBase"
12 SRC_URI="http://www.gnuvola.org/software/edb/${P}.tar.gz"
13
14 LICENSE="GPL-3+ Texinfo-manual"
15 SLOT="0"
16 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
17
18 ELISP_PATCHES="${P}-skram-path.patch"
19 SITEFILE="50${PN}-gentoo.el"
20
21 src_configure() {
22         default
23 }
24
25 src_compile() {
26         emake -j1
27 }
28
29 src_install() {
30         emake -j1 \
31                 sitelisp="${ED}${SITELISP}" \
32                 infodir="${ED}/usr/share/info" \
33                 install
34         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
35         dodoc AUTHORS BUGS ChangeLog HACKING NEWS README THANKS TODO doc/refcard.ps
36         dodoc -r examples
37 }