app-emacs/ebuild-mode: Remove old.
[gentoo.git] / app-emacs / distel / distel-4.1.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp
7
8 DESCRIPTION="Distributed Emacs Lisp for Erlang"
9 HOMEPAGE="https://massemanet.github.io/distel/
10         https://www.emacswiki.org/emacs/DistributedEmacsLisp"
11 SRC_URI="https://github.com/massemanet/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 # "New BSD License" according to https://code.google.com/p/distel/
14 # "MIT" according to https://github.com/massemanet/distel
15 LICENSE="BSD MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc"
19
20 RDEPEND=">=dev-lang/erlang-11.2.5[emacs]"
21 BDEPEND="${RDEPEND}"
22
23 SITEFILE="50${PN}-gentoo.el"
24
25 src_compile() {
26         emake base info
27         cd elisp || die
28         elisp-compile *.el
29 }
30
31 src_install() {
32         emake prefix="${ED}"/usr \
33                 ELISP_DIR="${ED}${SITELISP}/${PN}" install
34         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
35         doinfo doc/distel.info
36         dodoc AUTHORS ChangeLog NEWS README*
37         use doc && dodoc doc/gorrie02distel.pdf
38         docinto html
39         dodoc doc/distel/*.html
40 }