app-emacs/ebuild-mode: ppc stable wrt bug #706066
[gentoo.git] / app-emacs / cycle-buffer / cycle-buffer-2.16.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit elisp
7
8 DESCRIPTION="Select buffer by cycling through"
9 HOMEPAGE="https://www.emacswiki.org/emacs/cycle-buffer.el"
10 # taken from https://www.emacswiki.org/emacs/download/cycle-buffer.el
11 SRC_URI="https://github.com/gavv/distfiles/raw/master/${P}.el.xz"
12
13 LICENSE="public-domain"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 SITEFILE="50${PN}-gentoo.el"
18
19 src_compile() {
20         elisp-compile *.el
21         elisp-make-autoload-file
22 }