app-emacs/nxml-gentoo-schemas: ppc stable wrt bug #717324
[gentoo.git] / app-emacs / csharp-mode / csharp-mode-0.9.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp
7
8 DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
9 HOMEPAGE="https://github.com/josteink/csharp-mode"
10 SRC_URI="https://github.com/josteink/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15
16 SITEFILE="50${PN}-gentoo.el"
17
18 src_install() {
19         elisp-install ${PN} csharp-mode.el{,c}
20         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
21         dodoc README.org
22 }