Merge remote-tracking branch 'github/pr/703'. Fixes bug 560362.
[gentoo.git] / app-emacs / calfw / calfw-1.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit elisp eutils
8
9 DESCRIPTION="A calendar framework for Emacs"
10 HOMEPAGE="https://github.com/kiwanami/emacs-calfw"
11 SRC_URI="https://github.com/kiwanami/emacs-calfw/tarball/v${PV} -> ${P}.tar.gz"
12
13 LICENSE="GPL-3+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="howm"
17
18 DEPEND="howm? ( app-emacs/howm )"
19 RDEPEND="${DEPEND}"
20
21 SITEFILE="50${PN}-gentoo.el"
22
23 src_unpack() {
24         unpack ${A}
25         mv kiwanami-emacs-calfw-* ${P} || die
26 }
27
28 src_prepare() {
29         use howm || rm -f calfw-howm.el
30 }