dc92b6a17327adc2bdc1b3508cd6272142b8de50
[gentoo.git] / app-emacs / boxquote / boxquote-2.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp
7
8 DESCRIPTION="Quote text with a semi-box"
9 HOMEPAGE="http://www.davep.org/emacs/"
10 SRC_URI="https://github.com/davep/${PN}.el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-3+"
13 SLOT="0"
14 KEYWORDS="~amd64 ppc ppc64 ~x86"
15
16 S="${WORKDIR}/${PN}.el-${PV}"
17 SITEFILE="50${PN}-gentoo.el"
18 DOCS="README.md"
19
20 src_compile() {
21         elisp-compile *.el
22         elisp-make-autoload-file
23 }