app-emacs/bongo: Bump to version 1.1.
[gentoo.git] / app-emacs / bongo / bongo-20110621.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit elisp eutils
7
8 DESCRIPTION="Buffer-oriented media player for Emacs"
9 HOMEPAGE="http://www.brockman.se/software/bongo/"
10 # Darcs snapshot of http://www.brockman.se/software/bongo/
11 # MPlayer support from http://www.emacswiki.org/emacs/bongo-mplayer.el
12 SRC_URI="mirror://gentoo/${P}.tar.xz
13         mplayer? ( mirror://gentoo/${PN}-mplayer-20070204.tar.bz2 )"
14
15 LICENSE="GPL-2+ FDL-1.2+"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="mplayer"
19
20 # NOTE: Bongo can use almost anything for playing media files, therefore
21 # the dependency possibilities are so broad that we refrain from including
22 # any media players explicitly in DEPEND/RDEPEND.
23
24 RDEPEND="app-emacs/volume"
25 DEPEND="${RDEPEND}
26         sys-apps/texinfo"
27
28 S="${WORKDIR}/${PN}"
29 DOCS="AUTHORS HISTORY NEWS README.rdoc"
30 ELISP_PATCHES="${PN}-20070619-fix-require.patch
31         ${P}-texinfo-5.patch"
32 ELISP_REMOVE="bongo-emacs21.el" # Don't bother with Emacs 21
33 ELISP_TEXINFO="${PN}.texinfo"
34 SITEFILE="50${PN}-gentoo.el"
35
36 src_install() {
37         elisp_src_install
38         insinto "${SITEETC}/${PN}"
39         doins etc/*.pbm etc/*.png
40 }