profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / app-emacs / bbdb / bbdb-3.2_pre20180106.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp autotools
7
8 MY_P="${P%_pre*}"
9 DESCRIPTION="The Insidious Big Brother Database"
10 HOMEPAGE="https://savannah.nongnu.org/projects/bbdb/"
11 #SRC_URI="https://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
12 SRC_URI="https://git.savannah.nongnu.org/cgit/bbdb.git/snapshot/${MY_P}.tar.gz"
13 S="${WORKDIR}/${MY_P}"
14
15 LICENSE="GPL-3+ GPL-1+"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
18 IUSE="tex vm"
19 RESTRICT="test" #631700
20
21 BDEPEND="vm? ( app-emacs/vm )"
22 RDEPEND="${BDEPEND}
23         tex? ( virtual/latex-base )"
24
25 SITEFILE="50${PN}-gentoo-3.2.el"
26 TEXMF="/usr/share/texmf-site"
27
28 src_prepare() {
29         default
30         eautoreconf
31 }
32
33 src_configure() {
34         econf \
35                 --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
36                 "$(use_with vm vm-dir "${EPREFIX}${SITELISP}/vm")"
37 }
38
39 src_compile() {
40         emake -C lisp
41 }
42
43 src_install() {
44         emake -C lisp DESTDIR="${D}" install
45         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
46         dodoc AUTHORS ChangeLog NEWS README TODO
47
48         if use tex; then
49                 insinto "${TEXMF}"/tex/latex/${PN}
50                 doins tex/bbdb.sty
51         fi
52 }
53
54 pkg_postinst() {
55         elisp-site-regen
56         use tex && texconfig rehash
57 }
58
59 pkg_postrm() {
60         elisp-site-regen
61         use tex && texconfig rehash
62 }