profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / app-emacs / bbdb / bbdb-3.1.2-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp autotools
7
8 DESCRIPTION="The Insidious Big Brother Database"
9 HOMEPAGE="https://savannah.nongnu.org/projects/bbdb/"
10 SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-3+ GPL-1+"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~ia64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
15 IUSE="tex vm"
16 RESTRICT="test" #631700
17
18 BDEPEND="vm? ( app-emacs/vm )"
19 RDEPEND="${BDEPEND}
20         tex? ( virtual/tex-base )"
21
22 SITEFILE="50${PN}-gentoo-${PV}.el"
23 TEXMF="/usr/share/texmf-site"
24
25 src_prepare() {
26         eapply "${FILESDIR}"/${P}-no-init.patch
27         eapply_user
28         eautoreconf
29 }
30
31 src_configure() {
32         econf \
33                 --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
34                 "$(use_with vm vm-dir "${EPREFIX}${SITELISP}/vm")"
35 }
36
37 src_compile() {
38         emake -C lisp
39 }
40
41 src_install() {
42         emake -C lisp DESTDIR="${D}" install
43         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
44         dodoc AUTHORS ChangeLog NEWS README TODO
45
46         if use tex; then
47                 insinto "${TEXMF}"/tex/plain/${PN}
48                 doins tex/*.tex
49         fi
50 }
51
52 pkg_postinst() {
53         elisp-site-regen
54         use tex && texconfig rehash
55 }
56
57 pkg_postrm() {
58         elisp-site-regen
59         use tex && texconfig rehash
60 }