app-emacs/*: drop to ~hppa
[gentoo.git] / app-emacs / apel / apel-10.8_p20190407.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp
7
8 DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs"
9 HOMEPAGE="https://github.com/wanderlust/apel"
10 GITHUB_SHA1="d146ddbf8818e81d3577d5eee7825d377bec0c73"
11 SRC_URI="https://github.com/wanderlust/apel/archive/${GITHUB_SHA1}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
16
17 S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
18
19 src_prepare() {
20         elisp_src_prepare
21         cat <<-EOF >>APEL-CFG || die
22         (setq APEL_PREFIX "apel")
23         (setq EMU_PREFIX "apel")
24         EOF
25 }
26
27 src_compile() {
28         emake PREFIX="${ED}/usr" \
29                 LISPDIR="${ED}/${SITELISP}" \
30                 VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}"
31 }
32
33 src_install() {
34         emake PREFIX="${ED}/usr" \
35                 LISPDIR="${ED}/${SITELISP}" \
36                 VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" \
37                 install
38         elisp-site-file-install "${FILESDIR}/50apel-gentoo.el"
39         dodoc ChangeLog README*
40 }
41
42 pkg_postinst() {
43         elisp-site-regen
44         elog "See the README.en file in /usr/share/doc/${PF} for tips"
45         elog "on how to customize this package."
46 }