app-editors/adie: Removed old.
[gentoo.git] / app-editors / wily / wily-1.0-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit toolchain-funcs
6
7 MY_P="${P/1.0/9libs}"
8
9 DESCRIPTION="An emulation of ACME, Plan9's hybrid window system, shell and editor for programmers"
10 HOMEPAGE="http://www.netlib.org/research/9libs/"
11 SRC_URI="ftp://www.netlib.org/research/9libs/${MY_P}.tar.gz"
12
13 LICENSE="Artistic"
14 SLOT="0"
15 KEYWORDS="x86"
16 IUSE=""
17
18 DEPEND="dev-libs/9libs
19         >=x11-libs/libX11-1.0.0
20         >=x11-libs/libXt-1.0.0
21         >=x11-libs/libICE-1.0.0
22         >=x11-libs/libSM-1.0.0"
23
24 S="${WORKDIR}/${MY_P}"
25
26 src_compile() {
27         export CC="$(tc-getCC)"
28         econf --includedir="/usr/include/9libs" || die "configure failed."
29         emake || die "make failed."
30 }
31
32 src_install() {
33         make DESTDIR="${D}" install || die "make install failed."
34         dodoc README
35         insinto /usr/share/${PN}
36         doins "${S}"/misc/*
37 }