app-editors/vim-core: stable 8.2.0360 for sparc, bug #715732
[gentoo.git] / app-editors / lpe / lpe-1.2.6.13.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils ltprune multilib toolchain-funcs
6
7 DESCRIPTION="a lightweight programmers editor"
8 HOMEPAGE="https://packages.qa.debian.org/l/lpe.html"
9 SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}-0.1.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ppc sparc x86 ~x86-linux"
14 IUSE="nls"
15
16 RDEPEND=">=sys-libs/slang-2.2.4
17         >=sys-libs/ncurses-5.7-r7:0="
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig
20         nls? ( sys-devel/gettext )"
21
22 src_prepare() {
23         epatch "${FILESDIR}"/${P}-make-382.patch
24
25         # You should add PKG_CHECK_MODULES(NCURSES, ncurses) to configure.in and
26         # replace -lncurses in src/Makefile.am with $(NCURSES_LIBS)
27         # That is, if you need eautoreconf
28         sed -i \
29                 -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs-only-l ncurses):" \
30                 src/Makefile.in || die
31 }
32
33 src_configure() {
34         econf $(use_enable nls)
35 }
36
37 src_install() {
38         emake \
39                 libdir="${ED}/usr/$(get_libdir)" \
40                 prefix="${ED}/usr" \
41                 datadir="${ED}/usr/share" \
42                 mandir="${ED}/usr/share/man" \
43                 infodir="${ED}/usr/share/info" \
44                 docdir="${ED}/usr/share/doc/${PF}" \
45                 exdir="${ED}/usr/share/doc/${PF}/examples" \
46                 install
47
48         prune_libtool_files --all
49 }