dev-python/cryptography: Bump to 2.8
[gentoo.git] / app-editors / leo / leo-5.6.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_P="${PN}-editor-${PV}"
7 PYTHON_COMPAT=( python2_7 )
8 PYTHON_REQUIRED_USE="tk"
9 inherit distutils-r1
10
11 DESCRIPTION="Leo: Literate Editor with Outlines"
12 HOMEPAGE="https://github.com/leo-editor/leo-editor/"
13 SRC_URI="https://github.com/leo-editor/leo-editor/archive/${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18 IUSE="doc"
19
20 RDEPEND="
21         app-text/silvercity[${PYTHON_USEDEP}]
22         dev-python/PyQt5[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}"
25
26 S="${WORKDIR}/${MY_P}"
27
28 python_prepare_all() {
29         distutils-r1_python_prepare_all
30         cp leo/dist/setup.py leo/dist/leo-install.py . || die
31 }
32
33 python_install_all() {
34         use doc && local HTML_DOCS=( leo/doc/html/. )
35         distutils-r1_python_install_all
36 }