app-editors/gvim: Drop old
[gentoo.git] / app-editors / gummi / gummi-0.8.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit xdg-utils
7
8 DESCRIPTION="Simple LaTeX editor for GTK+ users"
9 HOMEPAGE="https://github.com/alexandervdm/gummi"
10 SRC_URI="https://github.com/alexandervdm/${PN}/releases/download/${PV}/${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm64 x86"
15 IUSE=""
16
17 RDEPEND="
18         app-text/gtkspell:3
19         app-text/poppler[cairo]
20         dev-libs/glib:2
21         dev-texlive/texlive-latex
22         dev-texlive/texlive-latexextra
23         x11-libs/gtk+:3
24         x11-libs/gtksourceview:3.0
25         x11-libs/pango
26 "
27 DEPEND="
28         ${RDEPEND}
29 "
30 BDEPEND="
31         dev-util/intltool
32         sys-devel/gettext
33         virtual/pkgconfig
34 "
35
36 pkg_postinst() {
37         xdg_desktop_database_update
38
39         elog "Gummi supports spell-checking through gtkspell. Support for"
40         elog "additional languages can be added by installing myspell-**-"
41         elog "packages for your language of choice."
42 }
43
44 pkg_postrm() {
45         xdg_desktop_database_update
46 }