app-editors/gvim: Drop old
[gentoo.git] / app-editors / gnome-latex / gnome-latex-3.32.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit gnome2
7
8 DESCRIPTION="Integrated LaTeX environment for GNOME"
9 HOMEPAGE="https://wiki.gnome.org/Apps/GNOME-LaTeX"
10
11 LICENSE="GPL-3+"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="+introspection +latexmk rubber"
15
16 COMMON_DEPEND="
17         >=app-text/gspell-1.8:0=
18         >=dev-libs/glib-2.56:2
19         >=dev-libs/libgee-0.10:0.8=
20         gnome-base/gsettings-desktop-schemas
21         >=x11-libs/gtk+-3.22:3
22         >=x11-libs/gtksourceview-4.0:4
23         >=gui-libs/tepl-4.2:4
24         x11-libs/gdk-pixbuf:2
25         x11-libs/pango
26         introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
27         gnome-base/dconf
28 "
29 RDEPEND="${COMMON_DEPEND}
30         virtual/latex-base
31         x11-themes/hicolor-icon-theme
32         latexmk? ( dev-tex/latexmk )
33         rubber? ( dev-tex/rubber )
34 "
35 DEPEND="${COMMON_DEPEND}
36         dev-util/gdbus-codegen
37         dev-util/glib-utils
38         >=dev-util/gtk-doc-am-1.14
39         >=dev-util/intltool-0.50.1
40         dev-util/itstool
41         virtual/pkgconfig
42 "
43
44 src_configure() {
45         gnome2_src_configure \
46                 $(use_enable introspection) \
47                 --enable-dconf_migration \
48                 APPSTREAM_UTIL="$(type -P true)" # Fails strict validation in 3.32.0
49 }