app-editors/vim-core: stable 8.2.0360 for sparc, bug #715732
[gentoo.git] / app-editors / emact / emact-2.58.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="EmACT, a fork of Conroy's MicroEmacs"
9 HOMEPAGE="http://www.eligis.com/emacs/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2+ BSD"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="X"
16
17 RDEPEND="sys-libs/ncurses:0=
18         X? ( x11-libs/libX11 )"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig
21         X? ( x11-base/xorg-proto )"
22
23 src_configure() {
24         econf \
25                 $(use_with X x) \
26                 LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
27 }
28
29 src_install() {
30         emake INSTALL="${ED%/}"/usr install
31         #dodoc README
32 }