Merge remote-tracking branch 'github/pr/608'.
[gentoo.git] / app-editors / diakonos / diakonos-0.9.4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 USE_RUBY="ruby20 ruby21"
8 inherit ruby-ng
9
10 DESCRIPTION="A Linux editor for the masses"
11 HOMEPAGE="http://diakonos.pist0s.ca"
12 SRC_URI="http://diakonos.pist0s.ca/archives/${P}.tar.bz2"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="doc test"
18
19 ruby_add_bdepend "doc? ( dev-ruby/yard )
20         test? ( dev-ruby/bacon )"
21
22 each_ruby_install() {
23         ${RUBY} install.rb --dest-dir "${D}" --doc-dir /usr/share/doc/${P} || die "install failed"
24 }
25
26 all_ruby_install() {
27         if use doc; then
28                 rake docs || die
29                 dodoc -r doc/*
30         fi
31 }
32
33 each_ruby_test() {
34         ${RUBY} -S bacon -Ilib spec/*.rb spec/*/*.rb || die
35 }