app-editors/mg: drop to ~hppa
[gentoo.git] / app-editors / dhex / dhex-0.68.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils toolchain-funcs
7
8 MY_P=${PN}_${PV}
9
10 DESCRIPTION="ncurses-based hex-editor with diff mode"
11 HOMEPAGE="http://www.dettus.net/dhex/"
12 SRC_URI="http://www.dettus.net/${PN}/${MY_P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ~mips x86"
17 IUSE=""
18
19 DEPEND="sys-libs/ncurses:="
20 RDEPEND="${DEPEND}"
21
22 S=${WORKDIR}/${MY_P}
23
24 src_prepare() {
25         epatch "${FILESDIR}"/${PN}-0.63-Makefile.patch
26 }
27
28 src_compile() {
29         emake \
30                 CC="$(tc-getCC)" \
31                 LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
32 }
33
34 src_install() {
35         dobin dhex
36         dodoc README.txt
37         doman dhex.1 dhex_markers.5 dhex_searchlog.5 dhexrc.5
38 }