dev-perl/Log-Dispatch-Array: Added at version 1.3.0
[gentoo.git] / app-doc / halibut / halibut-1.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="yet another free document preparation system"
8 HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/halibut/"
9 SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/${PN}/${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="amd64 ppc x86"
14 IUSE=""
15
16 src_compile() {
17         tc-export CC
18         CFLAGS="${CFLAGS} ${CPPFLAGS}" \
19         LFLAGS="${LDFLAGS}" \
20         emake -j1 \
21                 BUILDDIR="${S}/build" \
22                 VERSION="${PV}" \
23                 || die "make failed"
24
25         emake -C doc || die "make in doc failed"
26 }
27
28 src_install() {
29         dobin build/halibut || die
30         doman doc/halibut.1 || die
31         dodoc doc/halibut.txt
32         dohtml doc/*.html
33 }