dev-util/radare2: drop old
[gentoo.git] / app-doc / eclass-manpages / eclass-manpages-99999999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 inherit git-r3
7
8 DESCRIPTION="Collection of Gentoo eclass manpages"
9 HOMEPAGE="https://github.com/mgorny/eclass-to-manpage"
10 SRC_URI=""
11 EGIT_REPO_URI="https://anongit.gentoo.org/git/repo/gentoo.git
12         https://github.com/gentoo/gentoo.git"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS=""
17
18 BDEPEND="sys-apps/gawk"
19
20 src_unpack() {
21         git-r3_fetch
22         git-r3_fetch "https://github.com/mgorny/eclass-to-manpage"
23
24         git-r3_checkout '' '' '' eclass
25         git-r3_checkout "https://github.com/mgorny/eclass-to-manpage"
26 }
27
28 src_compile() {
29         emake ECLASSDIR=eclass
30 }
31
32 src_install() {
33         emake install ECLASSDIR=eclass DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
34 }