sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / app-dicts / myspell-pl / myspell-pl-20130306.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MYSPELL_DICT=(
7         "pl_PL.aff"
8         "pl_PL.dic"
9 )
10
11 MYSPELL_HYPH=(
12         "hyph_pl_PL.dic"
13 )
14
15 MYSPELL_THES=(
16         "th_pl_PL_v2.dat"
17         "th_pl_PL_v2.idx"
18 )
19
20 inherit myspell-r2
21
22 DESCRIPTION="Polish dictionaries for myspell/hunspell"
23 # dict is bumped every day but nothing changes, RECHECK BEFORE DOING VERSION BUMP!
24 # hyphen has no website
25 # thesarus released last in 2k8
26 HOMEPAGE="
27         http://www.sjp.pl/slownik/en/
28         https://sourceforge.net/projects/synonimy/
29 "
30 SRC_URI="
31         http://sjp.pl/slownik/ort/sjp-myspell-pl-${PV}.zip
32         http://www.openoffice.org/pl/pliki/hyph_pl_PL.zip -> ${P}-hyph.zip
33         mirror://sourceforge/synonimy/OOo2-Thesaurus-1.5.zip -> ${P}-thes.zip
34 "
35 LICENSE="CC-SA-1.0 LGPL-3 GPL-3 MPL-1.1"
36 SLOT="0"
37 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
38 IUSE=""
39
40 src_unpack() {
41         myspell-r2_src_unpack
42
43         # ZIPCEPTION!
44         unzip hyph_pl_PL.zip
45         unzip pl_PL.zip
46 }