proj/gentoo: Initial commit
[gentoo.git] / app-dicts / gwaei / gwaei-3.6.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 inherit gnome2-utils eutils
8
9 DESCRIPTION="Japanese-English Dictionary for GNOME"
10 HOMEPAGE="http://gwaei.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/gwaei/${P}.tar.xz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="gtk hunspell nls test mecab"
17
18 RDEPEND=">=net-misc/curl-7.20.0
19         >=dev-libs/glib-2.31
20         gtk? (
21                 x11-libs/gtk+:3
22                 >=app-text/gnome-doc-utils-0.14.0
23         )
24         hunspell? ( app-text/hunspell )
25         nls? ( virtual/libintl )
26         mecab? ( app-text/mecab )"
27 DEPEND="${RDEPEND}
28         test? (
29                 app-text/docbook-xml-dtd:4.1.2
30                 app-text/scrollkeeper-dtd
31         )
32         gtk? (
33                 x11-themes/gnome-icon-theme-symbolic
34                 >=app-text/gnome-doc-utils-0.14.0
35         )
36         nls? ( >=sys-devel/gettext-0.17 )
37         app-text/rarian
38         dev-util/intltool
39         virtual/pkgconfig"
40
41 src_configure() {
42         econf \
43                 $(use_with gtk gnome) \
44                 $(use_enable nls) \
45                 $(use_with hunspell) \
46                 $(use_with mecab) \
47                 --disable-static \
48                 --docdir=/usr/share/doc/${PF}
49 }
50
51 src_install() {
52         emake DESTDIR="${D}" install || die
53         find "${D}" -name '*.la' -delete
54
55         dodoc AUTHORS README
56 }
57
58 pkg_preinst() {
59         if use gtk ; then
60                 gnome2_schemas_savelist
61         fi
62 }
63
64 pkg_postinst() {
65         if use gtk ; then
66                 gnome2_schemas_update
67         fi
68 }
69
70 pkg_postrm() {
71         if use gtk ; then
72                 gnome2_schemas_update
73         fi
74 }