app-crypt/yubikey-manager: bump to 0.4.2
[gentoo.git] / app-crypt / yubikey-manager / yubikey-manager-0.4.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
7 inherit distutils-r1
8
9 DESCRIPTION="Python library and command line tool for configuring a YubiKey"
10 HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
11 SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
12
13 LICENSE="BSD-2"
14 SLOT="0"
15 KEYWORDS="~amd64"
16
17 RESTRICT="test" # Testing requires RSA keys which are not present in the tarball
18
19 RDEPEND="
20         app-crypt/libu2f-host
21         dev-python/six[${PYTHON_USEDEP}]
22         dev-python/pyscard[${PYTHON_USEDEP}]
23         dev-python/pyusb[${PYTHON_USEDEP}]
24         dev-python/click[${PYTHON_USEDEP}]
25         dev-python/cryptography[${PYTHON_USEDEP}]
26         dev-python/pyopenssl[${PYTHON_USEDEP}]
27         $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
28         sys-auth/ykpers
29 "