sys-apps/man-db: Added live ebuild.
[gentoo.git] / app-crypt / xca / xca-1.3.2-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit flag-o-matic autotools
7
8 DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
9 HOMEPAGE="http://xca.sourceforge.net"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
15 IUSE="bindist doc libressl"
16
17 RDEPEND="
18         dev-qt/qtgui:5
19         dev-qt/qtwidgets:5
20         !libressl? ( dev-libs/openssl:0=[bindist=] )
21         libressl? ( dev-libs/libressl:0= )
22         doc? ( app-text/linuxdoc-tools )"
23 DEPEND="${RDEPEND}"
24
25 PATCHES=(
26         "${FILESDIR}/${PN}-1.0.0-desktop.patch"
27         "${FILESDIR}/${P}-build.patch"
28 )
29
30 src_prepare() {
31         default
32         AT_M4DIR="m4" eautoreconf
33 }
34
35 src_configure() {
36         # bug #595440
37         append-cxxflags -std=c++11
38         econf \
39                 --with-qt-version=5 \
40                 $(use_enable doc) \
41                 STRIP=true
42 }
43
44 src_compile() {
45         # enforce all to avoid the automatic silent rules
46         emake all
47 }
48
49 src_install() {
50         # non standard destdir
51         emake install destdir="${ED}"
52         einstalldocs
53
54         insinto /etc/xca
55         doins misc/*.txt
56 }