Use https by default
[gentoo.git] / app-crypt / sgeps / sgeps-0_pre15.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 DESCRIPTION="simple GnuPG-encrypted password store written in perl"
8 HOMEPAGE="http://roland.entierement.nu/blog/2010/01/22/simple-gnupg-encrypted-password-store.html"
9 SRC_URI="https://dev.gentoo.org/~flameeyes/${PN}/${P}.tar.xz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE="zsh-completion"
15
16 RDEPEND="app-crypt/gnupg
17         dev-lang/perl
18         virtual/perl-Storable
19         virtual/perl-File-Temp
20         virtual/perl-Getopt-Long
21         dev-perl/Config-Simple
22         zsh-completion? ( app-shells/zsh )"
23 DEPEND=""
24
25 S="${WORKDIR}"
26
27 src_install() {
28         dobin sgeps pwsafe2sgeps
29         if use zsh-completion ; then
30                 insinto /usr/share/zsh/site-functions
31                 newins zsh-completion _sgeps
32         fi
33 }
34
35 pkg_postinst() {
36         elog "To make use of sgeps, remember to create a configuration file as"
37         elog " ~/.config/sgeps.conf with these values:"
38         elog ""
39         elog "store = ~/somewhere/safe"
40         elog "keyid = 012345678"
41         elog ""
42         elog "If you want to use the --copy options you should install x11-misc/xclip"
43 }