dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-crypt / seahorse / seahorse-3.32.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnome.org gnome2-utils meson xdg vala
6
7 DESCRIPTION="Manage your passwords and encryption keys"
8 HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
9
10 LICENSE="GPL-2+ FDL-1.1+"
11 SLOT="0"
12 IUSE="ldap zeroconf"
13 KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
14
15 RDEPEND="
16         >=dev-libs/glib-2.44:2
17         >=app-crypt/gcr-3.11.91:=
18         >=app-crypt/gpgme-1.7.0
19         >=x11-libs/gtk+-3.22.0:3
20         >=app-crypt/gnupg-2.0.12
21         >=app-crypt/libsecret-0.16
22         dev-libs/libpwquality
23         net-misc/openssh
24         ldap? ( net-nds/openldap:= )
25         >=net-libs/libsoup-2.33.92:2.4
26         zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
27 "
28 DEPEND="${RDEPEND}
29         $(vala_depend)
30         dev-libs/appstream-glib
31         dev-libs/libxml2:2
32         dev-util/gdbus-codegen
33         dev-util/glib-utils
34         dev-util/itstool
35         >=sys-devel/gettext-0.19.8
36         virtual/pkgconfig
37         app-crypt/gcr[vala]
38         app-crypt/libsecret[vala]
39 "
40
41 PATCHES=(
42         "${FILESDIR}"/${PV}-libsecret-0.20-compat.patch # included upstream for 3.34
43 )
44
45 src_prepare() {
46         xdg_src_prepare
47         vala_src_prepare
48 }
49
50 src_configure() {
51         local emesonargs=(
52                 -Dhelp=true
53                 -Dpgp-support=true
54                 -Dcheck-compatible-gpg=false # keep lowest version listed as compatible as min dep for gnupg RDEPEND
55                 -Dpkcs11-support=true
56                 -Dkeyservers-support=true
57                 -Dhkp-support=true
58                 $(meson_use ldap ldap-support)
59                 $(meson_use zeroconf key-sharing)
60         )
61         meson_src_configure
62 }
63
64 pkg_postinst() {
65         xdg_pkg_postinst
66         gnome2_schemas_update
67 }
68
69 pkg_postrm() {
70         xdg_pkg_postrm
71         gnome2_schemas_update
72 }