app-crypt/easy-rsa: ppc stable wrt bug #595998
[gentoo.git] / app-crypt / pesign / pesign-0.108.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils multilib
8
9 DESCRIPTION="Tools for manipulating signed PE-COFF binaries"
10 HOMEPAGE="https://github.com/vathpela/pesign"
11 SRC_URI="https://github.com/vathpela/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="libressl"
17
18 RDEPEND="
19         dev-libs/nspr
20         !libressl? ( dev-libs/openssl:0= )
21         libressl? ( dev-libs/libressl:0= )
22         sys-apps/util-linux
23 "
24 DEPEND="${RDEPEND}
25         sys-apps/help2man
26         sys-boot/gnu-efi
27         virtual/pkgconfig
28 "
29
30 src_prepare() {
31         epatch "${FILESDIR}"/destdir.patch
32 }
33
34 src_install() {
35         default
36
37         # remove some files that don't make sense for Gentoo installs
38         rm -rf "${ED}/etc/" "${ED}/usr/share/doc/pesign/" || die
39
40         # create .so symlink
41         ln -s libdpe.so "${ED}/usr/$(get_libdir)/libdpe.so.0"
42 }
43 #
44 #src_prepare() {
45 #       local iarch
46 #       case ${ARCH} in
47 #               ia64)  iarch=ia64 ;;
48 #               x86)   iarch=ia32 ;;
49 #               amd64) iarch=x86_64 ;;
50 #               *)     die "unsupported architecture: ${ARCH}" ;;
51 #       esac
52 #       sed -i "/^EFI_ARCH=/s:=.*:=${iarch}:" configure || die
53 #       sed -i 's/-m64$/& -march=x86-64/' tests/Makefile.in || die
54 #}