app-crypt/certbot: Keyword ~x86
[gentoo.git] / app-crypt / p11-kit / p11-kit-0.23.2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils multilib-minimal
8
9 DESCRIPTION="Provides a standard configuration setup for installing PKCS#11"
10 HOMEPAGE="https://p11-glue.freedesktop.org/p11-kit.html"
11 SRC_URI="https://p11-glue.freedesktop.org/releases/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="alpha ~amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
16 IUSE="+asn1 debug +libffi +trust"
17 REQUIRED_USE="trust? ( asn1 )"
18
19 RDEPEND="asn1? ( >=dev-libs/libtasn1-3.4[${MULTILIB_USEDEP}] )
20         libffi? ( >=dev-libs/libffi-3.0.0[${MULTILIB_USEDEP}] )
21         trust? ( app-misc/ca-certificates )"
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig"
24
25 pkg_setup() {
26         # disable unsafe tests, bug#502088
27         export FAKED_MODE=1
28 }
29
30 multilib_src_configure() {
31         ECONF_SOURCE="${S}" econf \
32                 $(use_enable trust trust-module) \
33                 $(use_with trust trust-paths ${EPREFIX}/etc/ssl/certs/ca-certificates.crt) \
34                 $(use_enable debug) \
35                 $(use_with libffi) \
36                 $(use_with asn1 libtasn1)
37
38         if multilib_is_native_abi; then
39                 # re-use provided documentation
40                 ln -s "${S}"/doc/manual/html doc/manual/html || die
41         fi
42 }
43
44 multilib_src_install_all() {
45         prune_libtool_files --modules
46 }