sys-block/btrace: Merge GitHub PR #1716
[gentoo.git] / app-crypt / ophcrack / ophcrack-3.6.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="6"
6 inherit eutils
7
8 DESCRIPTION="A time-memory-trade-off-cracker"
9 HOMEPAGE="http://ophcrack.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE="debug libressl qt4 +tables"
16
17 CDEPEND="!libressl? ( dev-libs/openssl:0= )
18                  libressl? ( dev-libs/libressl:0= )
19                  net-libs/netwib
20                  qt4? ( dev-qt/qtgui:4 )"
21 DEPEND="app-arch/unzip
22                 virtual/pkgconfig
23                 ${CDEPEND}"
24 RDEPEND="tables? ( app-crypt/ophcrack-tables )
25                  ${CDEPEND}"
26
27 PATCHES="${FILESDIR}/ophcrack-openssl-des.patch"
28
29 src_configure() {
30
31         local myconf
32
33         myconf="$(use_enable qt4 gui)"
34         myconf="${myconf} $(use_enable debug)"
35
36         econf ${myconf} || die "Failed to compile"
37 }
38
39 src_install() {
40         emake install DESTDIR="${D}" || die "Installation failed."
41
42         cd "${S}"
43         newicon src/gui/pixmaps/os.xpm ophcrack.xpm
44         make_desktop_entry "${PN}" OphCrack ophcrack
45 }