Merge remote-tracking branch 'github/pr/135'
[gentoo.git] / app-crypt / libsecret / libsecret-0.18.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 PYTHON_COMPAT=( python2_7 )
7 VALA_MIN_API_VERSION=0.18
8 VALA_USE_DEPEND=vapigen
9
10 inherit gnome2 python-any-r1 vala virtualx
11
12 DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
13 HOMEPAGE="https://live.gnome.org/Libsecret"
14
15 LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
16 SLOT="0"
17 IUSE="+crypt debug +introspection test vala"
18 REQUIRED_USE="vala? ( introspection )"
19 KEYWORDS="alpha amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-fbsd"
20
21 RDEPEND="
22         >=dev-libs/glib-2.38:2
23         crypt? ( >=dev-libs/libgcrypt-1.2.2:0= )
24         introspection? ( >=dev-libs/gobject-introspection-1.29 )
25 "
26 PDEPEND=">=gnome-base/gnome-keyring-3
27 "
28 # PDEPEND to avoid circular dep (bug #547456)
29 # Add ksecrets to PDEPEND when it's added to portage
30 DEPEND="${RDEPEND}
31         dev-libs/libxslt
32         dev-util/gdbus-codegen
33         >=dev-util/gtk-doc-am-1.9
34         >=dev-util/intltool-0.35.0
35         sys-devel/gettext
36         virtual/pkgconfig
37         test? (
38                 dev-python/mock
39                 introspection? (
40                         ${PYTHON_DEPS}
41                         >=dev-libs/gjs-1.32
42                         dev-python/pygobject:3 )
43         )
44         vala? ( $(vala_depend) )
45 "
46
47 src_prepare() {
48         use vala && vala_src_prepare
49         gnome2_src_prepare
50 }
51
52 src_configure() {
53         DOCS="AUTHORS ChangeLog NEWS README"
54         gnome2_src_configure \
55                 --enable-manpages \
56                 --disable-strict \
57                 --disable-coverage \
58                 --disable-static \
59                 $(use_enable crypt gcrypt) \
60                 $(use_enable introspection) \
61                 $(use_enable vala)
62 }
63
64 src_test() {
65         Xemake check
66 }