app-crypt/certbot-apache: 0.34.2 bump with cleanup
[gentoo.git] / app-crypt / libmd / libmd-1.0.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit multilib
6
7 DESCRIPTION="Message Digest functions from BSD systems"
8 HOMEPAGE="https://www.hadrons.org/software/libmd/"
9 SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
10
11 LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
14 IUSE="static-libs"
15
16 src_configure() {
17         econf $(use_enable static-libs static)
18 }
19
20 src_install() {
21         default
22
23         if ! use static-libs; then
24                 rm "${D}"/usr/$(get_libdir)/libmd.la || die
25         fi
26 }