app-crypt/gpa: Removed old.
[gentoo.git] / app-crypt / gpa / gpa-0.9.7.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 DESCRIPTION="The GNU Privacy Assistant (GPA) is a graphical user interface for GnuPG"
8 HOMEPAGE="http://gpa.wald.intevation.org"
9 SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
14 IUSE_LINGUAS=" ar cs de es fr ja nl pl pt_BR ru sv tr zh_TW"
15 IUSE="nls ${IUSE_LINGUAS// / linguas_}"
16
17 RDEPEND=">=x11-libs/gtk+-2.10.0:2
18         >=dev-libs/libgpg-error-1.4
19         >=dev-libs/libassuan-1.1.0
20         >=app-crypt/gnupg-2
21         >=app-crypt/gpgme-1.5.0"
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig
24         nls? ( sys-devel/gettext )"
25
26 src_prepare() {
27         sed -i 's/Application;//' gpa.desktop
28 }
29
30 src_configure() {
31         econf \
32                 --with-gpgme-prefix=/usr \
33                 --with-libassuan-prefix=/usr \
34                 $(use_enable nls) \
35                 GPGKEYS_LDAP="/usr/libexec/gpgkeys_ldap"
36 }