dev-python/xmlschema: arm64 stable (bug #723996)
[gentoo.git] / app-crypt / gpa / gpa-0.10.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="The GNU Privacy Assistant (GPA) is a graphical user interface for GnuPG"
7 HOMEPAGE="http://gpa.wald.intevation.org"
8 SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
13 IUSE="nls"
14
15 RDEPEND="
16         >=app-crypt/gnupg-2:=
17         >=app-crypt/gpgme-1.11.1:=
18         >=dev-libs/libassuan-1.1.0:=
19         >=dev-libs/libgpg-error-1.4:=
20         >=x11-libs/gtk+-2.10.0:2=
21 "
22 DEPEND="${RDEPEND}"
23 BDEPEND="virtual/pkgconfig
24         nls? ( sys-devel/gettext )"
25
26 src_prepare() {
27         default
28         sed -i 's/Application;//' gpa.desktop
29 }
30
31 src_configure() {
32         econf \
33                 --with-gpgme-prefix=/usr \
34                 --with-libassuan-prefix=/usr \
35                 $(use_enable nls) \
36                 GPGKEYS_LDAP="/usr/libexec/gpgkeys_ldap"
37 }