Use https by default
[gentoo.git] / app-crypt / gkeys / gkeys-0.1-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 PYTHON_COMPAT=(python{2_7,3_3,3_4})
8
9 inherit distutils-r1
10
11 DESCRIPTION="An OpenPGP/GPG key management tool for seed files and keyrings"
12 HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
13 SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.bz2"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 IUSE=""
18
19 KEYWORDS="~amd64 ~arm ~x86"
20
21 DEPEND=""
22 RDEPEND="${DEPEND}
23         app-crypt/gnupg
24         >=dev-python/pyGPG-0.1[${PYTHON_USEDEP}]
25         >=dev-python/ssl-fetch-0.3[${PYTHON_USEDEP}]
26         dev-python/snakeoil[${PYTHON_USEDEP}]
27         >=app-crypt/gentoo-keys-201501052117
28         "
29
30 python_install_all() {
31         distutils-r1_python_install_all
32         keepdir /var/log/gkeys
33         fperms g+w /var/log/gkeys
34 }
35
36 pkg_preinst() {
37         chgrp users "${D}"/var/log/gkeys
38 }
39
40 pkg_postinst() {
41         einfo "Fetching Gentoo Developer seed file..."
42         gkeys fetch-seed -C gentoo-devs || die "Unable to fetch seeds"
43         einfo "This is experimental software."
44         einfo "The API's it installs should be considered unstable"
45         einfo "and are subject to change."
46         einfo
47         einfo "Please file any enhancement requests, or bugs"
48         einfo "at https://bugs.gentoo.org"
49         einfo "We are also on IRC @ #gentoo-keys of the Freenode network"
50         einfo
51         ewarn "There may be some Python 3 compatibility issues still."
52         ewarn "Please help us debug, fix and report them in Bugzilla."
53 }