*/*: Specify EAPI=0 explicitly, to ease greps
[gentoo.git] / app-crypt / elettra / elettra-1.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit toolchain-funcs
7
8 MY_P="${PN}-src-${PV}"
9
10 DESCRIPTION="Plausible deniable file cryptography"
11 HOMEPAGE="http://www.winstonsmith.info/julia/elettra/"
12 SRC_URI="http://www.winstonsmith.info/julia/elettra/${MY_P}.tar.gz"
13
14 LICENSE="WTFPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
17 IUSE=""
18
19 RDEPEND="sys-libs/zlib
20                  app-crypt/mhash
21                  dev-libs/libmcrypt"
22
23 DEPEND="${RDEPEND}"
24
25 S="${WORKDIR}/${PN}"
26
27 src_compile() {
28         $(tc-getCC) ${CFLAGS} ${LDFLAGS} -I. src/*.c \
29                 -lz `libmcrypt-config --cflags --libs` -lmhash \
30                 -o elettra || die "compilation failed"
31 }
32
33 src_install() {
34         dobin elettra || die "dobin failed"
35         dodoc README || die "dodoc failed"
36 }