app-crypt/acme: Remove old
[gentoo.git] / app-crypt / easy-rsa / easy-rsa-2.2.2-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils
8
9 MY_P="EasyRSA-${PV}"
10
11 DESCRIPTION="Small RSA key management package, based on OpenSSL"
12 HOMEPAGE="http://openvpn.net/"
13 SRC_URI="https://github.com/OpenVPN/easy-rsa/releases/download/${PV}/${MY_P}.tgz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
18 IUSE="libressl"
19
20 DEPEND="!libressl? ( >=dev-libs/openssl-0.9.6:0 )
21         libressl? ( dev-libs/libressl )"
22 RDEPEND="${DEPEND}
23         !<net-misc/openvpn-2.3"
24
25 S="${WORKDIR}/${MY_P}"
26
27 src_prepare() {
28         epatch "${FILESDIR}/${PV}-pkcs11.patch"
29 }
30
31 src_install() {
32         exeinto /usr/share/easy-rsa
33         doexe build-* clean-all inherit-inter list-crl pkitool revoke-full sign-req whichopensslcnf
34         insinto /usr/share/easy-rsa
35         doins vars openssl-*.cnf
36         doenvd "${FILESDIR}/65easy-rsa" # config-protect easy-rsa
37 }