Merge github#785: net-libs/nodejs: removal
[gentoo.git] / app-crypt / codecrypt / codecrypt-1.7.2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 DESCRIPTION="Post-quantum cryptography tool"
8 HOMEPAGE="http://e-x-a.org/codecrypt/"
9 SRC_URI="http://e-x-a.org/codecrypt/files/${P}.tar.gz"
10
11 LICENSE="LGPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="+cryptopp"
15
16 DEPEND="dev-libs/gmp:=
17         cryptopp? ( dev-libs/crypto++ )
18         sci-libs/fftw:3.0"
19 RDEPEND="${DEPEND}"
20
21 src_prepare() {
22         eapply_user
23         # workaround -- gentoo is missing crypto++ pkg-config file
24         sed -i -e 's/PKG_CHECK_MODULES(\[CRYPTOPP\],.*/LDFLAGS="$LDFLAGS -lcrypto++"/' configure.ac
25         ./autogen.sh
26 }
27
28 src_configure() {
29         econf \
30                 $(use_with cryptopp )
31 }