1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
5 PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
7 if [[ ${PV} == 9999* ]]; then
8 EGIT_REPO_URI="https://github.com/certbot/certbot.git"
10 S=${WORKDIR}/${P}/${PN}
12 SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
13 KEYWORDS="~amd64 ~arm ~x86"
14 S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
19 DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
20 HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
26 CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
28 >=app-crypt/certbot-0.21.1[${PYTHON_USEDEP}]
29 >=app-crypt/acme-0.21.1[${PYTHON_USEDEP}]
30 dev-python/mock[${PYTHON_USEDEP}]
31 dev-python/pyopenssl[${PYTHON_USEDEP}]
32 >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
33 dev-python/zope-interface[${PYTHON_USEDEP}]"