app-crypt/certbot: 0.34.0 bump
[gentoo.git] / app-crypt / certbot / certbot-0.33.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=(python{2_7,3_5,3_6})
6
7 if [[ ${PV} == 9999* ]]; then
8         EGIT_REPO_URI="https://github.com/certbot/certbot.git"
9         inherit git-r3
10 else
11         SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12         KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
13 fi
14
15 inherit distutils-r1
16
17 DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
18 HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
19
20 LICENSE="Apache-2.0"
21 SLOT="0"
22 IUSE="test"
23
24 CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
25 RDEPEND="
26         ${CDEPEND}
27         >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
28         >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
29         dev-python/configobj[${PYTHON_USEDEP}]
30         >=dev-python/cryptography-1.2[${PYTHON_USEDEP}]
31         >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
32         dev-python/mock[${PYTHON_USEDEP}]
33         >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
34         dev-python/pyrfc3339[${PYTHON_USEDEP}]
35         dev-python/pytz[${PYTHON_USEDEP}]
36         dev-python/zope-component[${PYTHON_USEDEP}]
37         dev-python/zope-interface[${PYTHON_USEDEP}]"
38 DEPEND="
39         ${CDEPEND}
40         test? (
41                 dev-python/pytest[${PYTHON_USEDEP}]
42         )"
43
44 python_test() {
45         # acme is not installed, removing it here is fine, the dir just confuses tests
46         rm -R acme
47         pytest -vv ${PN} || die
48 }