Merge remote-tracking branch 'github/pr/463'.
[gentoo.git] / app-crypt / acme / acme-9999.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=(python{2_7,3_4,3_5})
7
8 if [[ ${PV} == 9999* ]]; then
9         EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
10         inherit git-r3
11         KEYWORDS=""
12         S=${WORKDIR}/${P}/${PN}
13 else
14         SRC_URI="https://github.com/letsencrypt/letsencrypt/archive/v${PV}.tar.gz -> letsencrypt-${PV}.tar.gz"
15         KEYWORDS="~amd64"
16         S=${WORKDIR}/letsencrypt-${PV}/acme
17 fi
18
19 inherit distutils-r1
20
21 DESCRIPTION="An implementation of the ACME protocol"
22 HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
23
24 LICENSE="Apache-2.0"
25 SLOT="0"
26 IUSE="test"
27
28 RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
29         dev-python/mock[${PYTHON_USEDEP}]
30         >=dev-python/ndg-httpsclient-0.4[${PYTHON_USEDEP}]
31         dev-python/pyasn1[${PYTHON_USEDEP}]
32         >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
33         dev-python/pyrfc3339[${PYTHON_USEDEP}]
34         dev-python/pytz[${PYTHON_USEDEP}]
35         dev-python/requests[${PYTHON_USEDEP}]
36         dev-python/six[${PYTHON_USEDEP}]
37         dev-python/werkzeug[${PYTHON_USEDEP}]"
38 DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
39         dev-python/setuptools[${PYTHON_USEDEP}]"
40
41 python_test() {
42         nosetests -w ${PN} || die
43 }