media-libs/portaudio: Version bump
[gentoo.git] / app-crypt / acme / acme-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 PYTHON_COMPAT=(python{2_7,3_4,3_5})
7
8 if [[ ${PV} == 9999* ]]; then
9         EGIT_REPO_URI="https://github.com/certbot/certbot.git"
10         inherit git-r3
11         S=${WORKDIR}/${P}/${PN}
12 else
13         SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
14         KEYWORDS="~amd64 ~arm ~x86"
15         S=${WORKDIR}/certbot-${PV}/acme
16 fi
17
18 inherit distutils-r1
19
20 DESCRIPTION="An implementation of the ACME protocol"
21 HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
22
23 LICENSE="Apache-2.0"
24 SLOT="0"
25 IUSE="test"
26
27 RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
28         dev-python/mock[${PYTHON_USEDEP}]
29         >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
30         dev-python/pyrfc3339[${PYTHON_USEDEP}]
31         dev-python/pytz[${PYTHON_USEDEP}]
32         >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
33         dev-python/six[${PYTHON_USEDEP}]
34         virtual/python-dnspython"
35 DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
36         >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
37
38 python_test() {
39         nosetests -w ${PN} || die
40 }