app-cdr/cdemu: amd64 stable wrt bug #697446
[gentoo.git] / app-cdr / xfburn / xfburn-0.5.5-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2-utils xdg-utils
7
8 DESCRIPTION="GTK+ based CD and DVD burning application"
9 HOMEPAGE="https://goodies.xfce.org/projects/applications/xfburn"
10 SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 arm ~ppc x86"
15 IUSE="gstreamer +udev"
16
17 RDEPEND=">=dev-libs/glib-2.32:=
18         >=dev-libs/libburn-0.4.2:=
19         >=dev-libs/libisofs-0.6.2:=
20         >=x11-libs/gtk+-2.24:2=
21         xfce-base/exo[gtk2(+)]
22         >=xfce-base/libxfce4ui-4.10:=[gtk2(+)]
23         gstreamer? (
24                 media-libs/gstreamer:1.0=
25                 media-libs/gst-plugins-base:1.0= )
26         udev? ( dev-libs/libgudev:= )"
27 DEPEND="${RDEPEND}
28         dev-util/intltool
29         sys-devel/gettext
30         virtual/pkgconfig"
31
32 src_configure() {
33         local myconf=(
34                 $(use_enable udev gudev)
35                 $(use_enable gstreamer)
36         )
37
38         econf "${myconf[@]}"
39 }
40
41 pkg_postinst() {
42         gnome2_icon_cache_update
43         xdg_desktop_database_update
44 }
45
46 pkg_postrm() {
47         gnome2_icon_cache_update
48         xdg_desktop_database_update
49 }