app-cdr/xbiso: Fix license to GPL-2+
[gentoo.git] / app-cdr / xbiso / xbiso-0.6.1-r3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools flag-o-matic
6
7 DESCRIPTION="Xbox xdvdfs ISO extraction utility"
8 HOMEPAGE="https://sourceforge.net/projects/xbiso/"
9 SRC_URI="mirror://sourceforge/xbiso/${P}.tar.gz"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
14 IUSE="ftp"
15
16 RDEPEND="ftp? ( <net-libs/ftplib-4 )"
17 DEPEND="${RDEPEND}"
18
19 src_prepare() {
20         eapply_user
21         sed -i -e 's:C) $(CFLAGS):C) $(LDFLAGS) $(CFLAGS):' Makefile.in || die #337769
22         eapply "${FILESDIR}/${P}-libs.patch"
23         mv configure.in configure.ac || die #426262
24         eautoreconf
25 }
26
27 src_configure() {
28         # for this package, interix behaves the same as BSD
29         [[ ${CHOST} == *-interix* ]] && append-flags -D_BSD
30
31         econf \
32                 $(use_enable ftp)
33 }
34
35 src_install() {
36         dobin xbiso
37         dodoc CHANGELOG README
38 }