app-cdr/xbiso: Remove masked USE=ftp
[gentoo.git] / app-cdr / xbiso / xbiso-0.6.1-r3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools flag-o-matic
6
7 DESCRIPTION="Xbox xdvdfs ISO extraction utility"
8 HOMEPAGE="https://sourceforge.net/projects/xbiso/"
9 SRC_URI="mirror://sourceforge/xbiso/${P}.tar.gz"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
14 IUSE=""
15
16 src_prepare() {
17         eapply_user
18         sed -i -e 's:C) $(CFLAGS):C) $(LDFLAGS) $(CFLAGS):' Makefile.in || die #337769
19         eapply "${FILESDIR}/${P}-libs.patch"
20         mv configure.in configure.ac || die #426262
21         eautoreconf
22 }
23
24 src_configure() {
25         # for this package, interix behaves the same as BSD
26         [[ ${CHOST} == *-interix* ]] && append-flags -D_BSD
27
28         econf --disable-ftp
29 }
30
31 src_install() {
32         dobin xbiso
33         dodoc CHANGELOG README
34 }