app-cdr/mirage2iso: Bump to EAPI 6, clean up
[gentoo.git] / app-cdr / mirage2iso / mirage2iso-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
8 inherit autotools git-r3
9
10 DESCRIPTION="CD/DVD image converter using libmirage"
11 HOMEPAGE="https://bitbucket.org/mgorny/mirage2iso/"
12 SRC_URI=""
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE="pinentry test"
18
19 COMMON_DEPEND=">=dev-libs/libmirage-2.0.0:0=
20         dev-libs/glib:2=
21         pinentry? ( dev-libs/libassuan:0= )"
22 DEPEND="${COMMON_DEPEND}
23         dev-libs/libassuan
24         virtual/pkgconfig
25         test? ( app-arch/xz-utils )"
26 RDEPEND="${COMMON_DEPEND}
27         pinentry? ( app-crypt/pinentry )"
28
29 RESTRICT="!test? ( test )"
30
31 src_prepare() {
32         default
33         eautoreconf
34 }
35
36 src_configure() {
37         local myconf=(
38                 $(use_with pinentry libassuan)
39         )
40
41         econf "${myconf[@]}"
42 }