sys-libs/glibc: update 2.29 branch to EAPI=7
[gentoo.git] / app-cdr / gtkcdlabel / gtkcdlabel-1.15.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit python-single-r1
8
9 DESCRIPTION="A GUI for cdlabelgen that generates CD labels"
10 HOMEPAGE="http://gtkcdlabel.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ppc ~sparc x86"
16 IUSE=""
17
18 DEPEND="${PYTHON_DEPS}
19         >=app-cdr/cdlabelgen-4
20         dev-python/pygtk[${PYTHON_USEDEP}]"
21 RDEPEND="${DEPEND}"
22
23 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
24
25 S="${WORKDIR}"
26
27 src_prepare() {
28         default
29         python_fix_shebang .
30 }
31
32 src_install() {
33         dobin "usr/bin/${PN}.py"
34         insinto /usr/share
35         doins -r usr/share/{applications,"${PN}",pixmaps}
36         dodoc usr/share/doc/"${PN}"/{AUTHORS,README}
37 }