dev-util/clair: 2.1.3 bump
[gentoo.git] / app-cdr / gaffitter / gaffitter-0.6.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 SV="0.1.0"
9 SCRIPTS="scripts-${SV}"
10
11 DESCRIPTION="Genetic Algorithm File Fitter"
12 HOMEPAGE="http://gaffitter.sourceforge.net/"
13 SRC_URI="
14         mirror://sourceforge/${PN}/${P}.tar.bz2
15         scripts? ( mirror://sourceforge/${PN}/scripts/${SV}/${SCRIPTS}.tar.bz2 )"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="amd64 x86"
20 IUSE="scripts"
21
22 PATCHES=( "${FILESDIR}"/${PN}-0.6.0-fix-build-system.patch )
23
24 src_prepare() {
25         default
26
27         if use scripts; then
28                 sed -i -re "s:--data((cd)|(dvd)):--data:" "${WORKDIR}"/${PN}/${SCRIPTS}/gaff-k3b || die
29         fi
30 }
31
32 src_configure() {
33         tc-export CXX
34 }
35
36 src_install() {
37         dobin src/gaffitter
38         einstalldocs
39
40         if use scripts; then
41                 dobin "${WORKDIR}"/${PN}/${SCRIPTS}/gaff-**
42                 dobin "${WORKDIR}"/${PN}/${SCRIPTS}/nautilus/nautilus-*
43         fi
44 }